Jump to content
Salesforce and other SMB Solutions are coming soon. ×

owangolama
 Share

Recommended Posts

I'm using Automator to do a few things in a Web Viewer (like mostly clicking web links).

 

I've finally figured out how to call the Automator applet thingies that I've created, but they get an error:

 

The action “Watch Me Do” encountered an error.

Check the actionʼs properties and try running the workflow again.

 

I have initially solved this by going to System Preferences > Security & Privacy and choosing the application. But recently some of the applets seem to have lost their privilege to drive the interface and I'm getting the error again. I tried unchecking and checking the app in Security & Privacy, and then deleting it and adding it again (both manually and by way of FM suggesting it). Nothing works. It seems that I can get it to work by completely recreating the applet, but obviously this is not a tenable solution since it creates a situation where I'm spending MORE time solving the problem than the time that it saves me.

 

Any ideas how to get it to work forever? Any advice is greatly appreciated.

 

Would also be really interested if other people are using other solutions to simulate an automated click in the Web Viewer. I've done a lot of searching on the subject and not really come up with much. AppleScript seems like an option, but that has proven problematic as well.

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use