Jump to content
Salesforce and other SMB Solutions are coming soon. ×

MWile
 Share

Recommended Posts

I have a script that includes a step to import an Excel sheet using "Custom Order." When I run the script using Script Debugger, the option has changed to "Last Order" and the items are now in the incorrect order. Any ideas on why this is happening? Also, I'd like to check the "Don't import first record (contains field names)" checkbox but it's grayed out. That's no biggie as I can just remove the first line. I would like to retain the custom order, though.

Link to comment
Share on other sites

The Import script step has a few quirky behaviors. Does it import correctly if you just run the script without the debugger? Are you showing the Import dialog during the script?

 

As for the "Don't import first record..." option, try adding 1 record to the table first. I believe there has to be 1 existing record in the table for that to work.

Link to comment
Share on other sites

If I don't have the debugger on, it runs because it uses "last order." Not sure if I ran a script with different parameters and then ran this script. Would it pick up "last order" from the other script?

Link to comment
Share on other sites

Make a copy of the file and test it on the copy. Run the script. Verify its correct. Do a manual import of some other file with different data with different settings. Run the script again...verify if the data is correct.

 

But if you are not showing the sort order dialog, you wouldn't know if it ran with "Last Order" or ran as it was saved.

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use