Jump to content
Salesforce and other SMB Solutions are coming soon. ×

Open word file mac


HexxaBubba
 Share

Recommended Posts

I Have a script that uses open url to open Word documents in a folder: Works Perfect!

 

"C:\Documents and Settings\Me\My Documents\Word\\" & Contacts::First & " " & Contacts::Last & ".doc"

 

Trying to duplicate this in MAC; and having Problems. What should a similar (filepath) look like in MAC?

 

Thanks Again!!

Link to comment
Share on other sites

Open URL ["file:///Users/Me/Documents/Word/"&Contasts::First & " "&Contasts::Last&".doc", no dialog]

 

or

 

Open URL ["filemac://" & Get(DocumentsPath)& "/Word/"&Contasts::First & " "&Contasts::Last&".doc", no dialog]

Link to comment
Share on other sites

Al, I tried these and all i get is safari..

 

I actually made calc fields with Get(desktoppath) and other paths. I copy pasted paths in text field and put that in Open Url script with document name at end...No go..I played around with different combos and no go....

 

desktop path looks like /HardDriveName/Users/me/Desktop/

 

Do I need to include HD name. I feel like I've tried it every way. One thing that does work; place document in container field as a reference and if you click it will open document...But I can't script it.. i have tried send event, open url, and export field contents. All successful in windows; but Mac only when file is inserted...

 

Sorry, but I'm dieing over here...

Link to comment
Share on other sites

You should be able to script it:

 

Go to Field [select/play, YourTable::YourContainerField]

 

I don't understand why the heck Safari would leap up to handle an URL type of file:// ???!???]

 

Sure doesn't do that on MY Mac! I am sitting here right now with a solution that has a global text field "g.Path to Movies" which happens to contain this text: /Secondary/Files from Silurian/Personal Stuff/Support Group/

 

The button executes Open URL ["file:///Volumes/"&Showcase::g.Path to Movies]

 

It opens in Finder, not Safari. (it's a folder). If I change the Open URL to this:

 

Open URL ["file:///Volumes/"&Showcase::g.Path to Movies&"/"&Showcase::MovieName]

 

... it opens in QuickTime movie player (because now the path goes to a file, a .mov file in fact.

 

 

 

Something's weird about your system if Safari is the default handler for a "file://" URL

 

(unless perhaps the file itself ends in ".htm" or ".html" ?)

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use