Jump to content
Salesforce and other SMB Solutions are coming soon. ×

Multi-User problem over a network - HELP!


Recommended Posts

Hello everyone - I am totally new to this forum, and nearly as new to FileMaker in general. I did a search for my issue, and found some answers that are close, but not exact. My apologies in advance for my lack of experience and the inevitable naivety of my questions. Having said that, on to the problem at hand.


I work at Sony Animation on the new Spider-Man cartoon. We have an archaic version of FileMaker, Version 6, that we still use for various operations, in this case calling retakes. We are using MAC OSX. Anyway, we have a Filemaker server somewhere out there in the ether that holds all the actual data, and another data server (we'll call it Spidey) that handles storage of artwork and common files. There is a FileMaker database file on Spidey that we all want to use.


So here's the issue. We all want to be able to log into that file and add data to it. I had it set up as multi-user file, and initially we each copied the file to our desktop so we could easily access it. We were all able to open the file and input data no problem. The problem was that when user 1 would enter information, user 2 would not see it, nor would anyone else that opened the file on from the Spidey server. Basically the information was not updating, it was only being seen on the computer of whomever was entering the new data.


SO instead of copying the file to the individual users' computers, I made a shortcut of the file and put that on each user's dock. That didn't work either - same issue. I've gotta think there is some fundamental small thing I am missing here, but I'm too new to FileMaker to really know what I'm doing. Can anyone help? Please let me know if you need more information.


Thanks everyone, for reading my novel and for your assistance!

Link to comment
Share on other sites

For a limited number of concurrent users (I believe 10 max, but performance wise it will be less) you can use a dedicated host computer using filemaker pro. Users can open the file with the open remote... menu command from the local filemaker copy.

Do not use shortcuts, and OS level file sharing, it is a cause of database corruption.


In most cases with multiple concurrent users, Filemaker Server is advised.

You're going to need Server version 5.5. This is no longer shipped by Filemaker Inc. Perhaps you can find it on amazon or ebay, but watch out for pirated software.

The alternative is to upgrade the whole show to version 9 (server + fm pro) as 5 and 9 are not compatible (you can convert version 5 files to version 9 files but not the other way round). But the same advice applies as to networking.

Link to comment
Share on other sites

Thanks kjoe


That solved my problem for the short term. At least someone else can access the database while I'm doing fixes. I still need to figure out the long term solution. There is a filemaker server out there somewhere - we used it on a previous production and it worked fine. For some reason however, this one is not. I'll have to figure it out with our server person (wish me luck with that one).



Link to comment
Share on other sites

You should be aware that version 5-6 (in fact any version below 8.5) is not made for Mac 10.5 (leopard). So you might encounter problems from this.


- only version 9 is certified and supported

- version 8.5 will operate except Instant Web Publishing after installing a patch from filemaker.com

- other versions have not been tested and will not be supported

That said, I am not aware of any large issues regarding version6 under leopard, but I haven't been paying attention to it either.

Link to comment
Share on other sites

And if you're on an Intel-powered Mac, you're running the whole thing in emulation, in Rosetta, your Intel chip executing PowerPC code and taking a speed hit as a consequence.

Link to comment
Share on other sites

Interesting information - I'll take that under advisement. Sony is not exactly up to speed with the latest software (obviously, I mean we're using version6 of FileMaker...). We are still running OSX 10.4. The machines are intel chips however.


Useful info - thanks

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use