Jump to content
Salesforce and other SMB Solutions are coming soon. ×

Auto Enter Calculation Field Problems


karibarikix
 Share

Recommended Posts

Hello Everyone,

 

I have made a database that will hold all of our data on samples that we make. I have written a script that will import new records. But for some reason when I import the records in this manner... my calculated fields do not evaluate. They will evaluate when I say file new and type in the field that are being referenced in the calculation. Can anyone help?

 

Kari

Link to comment
Share on other sites

It was a known glitch with FileMaker 7.0v1.

 

From FileMaker Solutions Alliance postings in the early days of FmPro 7:

 

At 2:38 AM -0800 3/12/04, wrote:

I have a number calculation field called: cConstant_n =1. When I import records from another file, the imported records show "nothing" in the calculation.

 

How can this be? It's a calc??

 

then later:

 

At 2:28 AM -0800 3/13/04, wrote:

I tried this again and what I discovered is this: If the Perform auto enter etc... is checked, the calculated result will have a value in the imported records. If not, the calculation is empty. Sounds like a bug since the calcuation is not even calculating anything, it just = 1.

 

and

 

At 2:28 AM -0800 3/13/04, wrote:

Definitely a bug. I reported it this morning. This can't be on purpose because you could never update files if you have to perform lookups, auto enter etc.

 

I just thought I would check to see if all calculations are doing this or only 'stored' calculations. Guess what?? Only 'stored' calculations are affected. Unstored calculations seem to be fine.

 

 

From subsequent discussion, it looks like the solution was to open the affected stored calc fields, change the checkbox in the "Storage" tab to "Unstored", save field definitions, go back in, switch it back to "Stored", and that kicks FileMaker's indexing routine into action and the new index works.

 

Later versions of FileMaker don't seem prone to this problem but it seems to have been fixed by the time of FileMaker 8.

Link to comment
Share on other sites

Thank you for your quick response but i'm not too sure what you mean by uncheck the "Unstored" box in the Storage tab. My storage tab only has "Global storage", "repeating", and "Indexing". Am I looking in the wrong area?

Link to comment
Share on other sites

Indexing

 

 

The box where it says "Do not store calculation results -- recalculate when needed". (You're right it doesn't say "unstored")

 

Check it, OK it, OK field defs in general, reopen field defs, uncheck it, OK it again, close field defs again. That's supposed to fix it.

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use