Jump to content
Salesforce and other SMB Solutions are coming soon. ×

File Closed On Server will not change to Normal


Schmukey
 Share

Recommended Posts

Greetings,

 

I have a file on my server FMS8 which I have been working on for the last few months without any problems, however, this morning I came in and moved my copy I had been working on at home to the server and the file stays in closed status, I cant make it go into normal at all.

 

I can put the old file back in place and it works, but the new file will not. There were no major changes to the file other than some script work.

 

Anyone know what I may have done to cause the file to stick in Closed mode?

 

Thanks in advance.

Link to comment
Share on other sites

Sorry to get your hopes up Schmukey, but I'm in the same boat - however, I have several backups of the file in question, and yet, when server 8.04 lost interest in opening v9 of this file, I went, back to 8, then 7, and still no go! Things went south when I was futzing with file permissions, so I think I am going to look for a preference that is remembering the identity of the file, rather than the file itself, as any version of this file is now taboo.

Link to comment
Share on other sites

It sounds like y'all are editing a local copy of the file in question and then moving it onto the FmServer box.

 

How are you doing that? Pretend I'm REALLY STOOOPID and explain in excruciating detail how you are getting the newly-edited file from a local machine onto the FmServer box.

 

Start with whether or not you've got it open in FileMaker on your local computer.

Link to comment
Share on other sites

excruciating detail

In my case, when I first loaded this set of alpha files up I forgot to set permissions and served them as fmadmin read only. Three files opened, I logged in, realized the mistake, [doi!] logged out, went to files, changed permissions to read & write, owner to fmserver, group to fmadmin, three files opened, THIS time in the log stating for each 'opened for the first time" and the third file failed the consistency check. Re-serving a copy of the original file from backup, which had passed CC earlier as read-only and loaded, but now first correctly setting permissions, did not pass CC. Had to go back several days to get a good one. NONE had ever been served before: this was the first load for this file. No explanation of why it loaded fine several times then died, then earlier never loaded before copies also dies. Perhaps a read-only file is treated differently and would not have passed a CC had the permissions been set correctly on the first test load.

 

The event.log was interesting reading.

 

For me, no biggy as these are test files. The dead file is simple in all ways, nor had I revised at all in days (so why had a simple, barely touched file failed CC? That's scary!). Of course I wasted hours trying to recreate the snafu with various backup copies and couldn't.

I did notice in the log that Server has an option to enable to load without a consistency check. I'd be tempted to play more, but my day is over. I wonder how quickly one can rebuild a file in FM8 with importing tables, data, pasting in layouts, and importing scripts? TG I don't need to.

Link to comment
Share on other sites

I am having the same problem for the first time today - and I've successfully added two previous databases to the server only 2 months ago.

 

Today I dragged the database in question onto the server desktop from a flash drive, altered the extended privileges and the permissions and then dragged it into the Library/FMServer/Data/Databases folder.

 

Permissions and privileges are correct (identical to all the other FM8 files on the server) and it's in the same folder as the other files but I cannot change its status to Normal. When I try to do so the word "Closed" flickers, but doesn't change. As far as I know I haven't done anything differently from the last time I added a database to the server.

 

I have tried the following, without result:

Opening the database in FM8 to make sure its functional first, then closing it and quitting FM8 before dragging it into the databases folder.

Restarting

Dragging the database directly from the flash drive to the folder

Removing the problem database, renaming it and trying again

Removing the problem database, saving as another name and trying again

Closing all the databases and then reopening them - all opened except the one I'm having the problem with. (I did this at file level and at folder level)

Link to comment
Share on other sites

notaclone, I'm sorry but that is not the answer to the question that I asked.

 

File is on local computer where you've worked on it. File ENDS UP on the FileMaker Server computer, presumably not the same computer.

 

How did it get there? Did you burn a CD and walk it over, insert the CD, drag file off CD into the folder? Did you put it on a floppy? A Zip? A SyQuest ;)? Did you do a copy over network from your computer to the FmServer box? If so, did you sit at the FmServer box and navigate to your shared drive on your regular computer and pull it, or did you sit at your regular computer and open a window to the FmServer and drag the file into that window?

 

Was the old copy of the file served up by FileMaker Server at the time you replaced it, or did you shut FileMaker Server down first or unshare the file that was about to be replaced?

 

And, as I said before, was the file that you'd been editing closed, not open in your local copy of FileMaker, prior to you burning it to CD, copying it to floppy or Zip or whatever, or copying it over the network? Or did you quit out of FileMaker before copying the file?

Link to comment
Share on other sites

Itried the following...

Ouch! We are having the same day! (I also tried deleting caches and redoing FM server preferences). If your event log states the same consistency check error I imagine you have your work cut out for you. I know they advise only using recover to retrieve lost data from a file, and returning to a sound structure file from backup to import that data to. In my other reading I suspect I may have damaged my file by sleeping the computer while editing a few days ago.

I'm still trying to figure out when my file became "unserverable", as a back up copy that loaded earlier is not, now. This file is used to store documents, and has a handful of pdfs and excel files in it. hmmm.

event.log:

Good round:

"File" consistency check succeeded, database opened.

Bad round:

"File" is being opened for the first time in FileMaker 8, performing consistency check...

"File" could not be opened. Database may be damaged; use the Recover command in FileMaker Pro 8.

Link to comment
Share on other sites

FYI- files are transfer via AFP. Server OSX3.9, Workstation OSX4.7.

FMA remote: Close all database files. Refresh to confirm result.

AFP Mounted volume: delete file. upload file.

On server locally: set permissions group to fmadmin R/W then owner from owner account name to fmserver.

FMA remote: refresh databases, open.

Only recent copies of this one file fail, all other files and older versions are fine whether I change use FMA remotely or locally on server, and even whether I set permissions remotely or local (tried remote for experiment).

FMPA85 was closed the entire time. Restore of Backup copies sources varied: iDisk, Retro, Backup, and dragged copies, always with all applications other that the backup app closed. The file hasn't really changed in days, so I will just use the working one from earlier in the week.

Link to comment
Share on other sites

Well after spending hours figuring out when my file became "inconsistent", and trying to recreate the problem on another file to see if there was anyway to cause it by "mis-serving", (couldn't) I went back to my most recent version and found saving a copy as compacted worked quite nicely to get that file opening again. Such a silly day. I'll stick with my backup file anyway.

Link to comment
Share on other sites

FYI, it has long been a matter of formidable important and part of the canon of established Truth with a capital "T" in the FSA that you do not run any type of file sharing on an FmServer box. Not AFP. Not SMB. Nuthin'. Also that you should turn off every Windows or OSX process that isn't essential, to cut down on things that read from and write to the drive. (No anti-virus and no indexing of files on drive, for instance). But file sharing has always been the One Really Wrong Thing to have turned on.

 

Be that as it may, it's unlikely to have corrupted a file that just got copied over there while FmServer was shut down.

 

Is the file by any chance a legacy file that has been converted from fp3 to fp5 and then to fp7? Crashed several times on local server, maybe even been Recovered once or twice and kept in use rather than the records being imported into the proverbial Reliably Known Good Clone?

 

If it's a brand new file (plus or minus) and hasn't been subjected to that kind of abuse, it's really odd that FmServer would stick its nose up about serving it. The most common culprit in files-that-won't-serve, in my experience, is files that weren't closed properly, which is caused by copying files that were open (by FmPro or by FmServer) at the time of copying. Which you said you did not do. Second most common is files that have been through hell & back (Recovered, crashed over and over again, opened over a network via "Finder" instead of Open:Hosts, backed up via backup software while still served up by FmServer night after night, that kind of thing)

Link to comment
Share on other sites

Thank you AHunter3 for responding with further suggestions.

 

I made an empty clone and imported the records and used that. It worked perfectly the first time.

 

Many, many thanks - I was going crazy with this.

 

Cheers

~ Inkling

Link to comment
Share on other sites

The saving a file as compacted worked for me also. I'm not sure at what point the file converted to closed. In my case I was moving the file in and out of the Library/FileMaker Server/Data/Databases folder to change some Accounts & Privileges settings. It is quite possible I had not shut down FM Server during one of those transfers.

 

I'm running FileMaker Server Advanced on just one computer.

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use