Jump to content
Salesforce and other SMB Solutions are coming soon. ×

Engish date fields glitchy on Japanese Mac OS


clab
 Share

Recommended Posts

I have an FMP file of English language data, but I'm running FMP on a Japanese configured Mac OS computer. For this particular database, I don't need Japanese at all.

 

My date fields are stuck in a Japanese font, and I can't change it. Going to Define > Database > [select field] > Options > Storage > Default lanaguage, I see Japanese is there and is dimmed.

 

I also cannot get the Insert Date command to insert a date that is accepted. It puts a Japanese hankaju katakana "mi" in place of the hyphens.

 

My file complains on launch that the date and time formats are different from the systems, and asks me which to use.

 

I've fiddled with my system's date formats, and they seem to be what I want, but that format is not inserted by the Insert Date format. I've looked at, in Layout Mode, the Format > Date screen, choosing the field in question, and choosing either Format or Custom with the format I want, but it isn't fixed.

 

How do I just get this file to think it's an English file on an English computer and stop complaining and stop entering oddball date formats?

Link to comment
Share on other sites

It would be helpful to know what were the operating system's settings when the file was created. A file inherits number/date/time format settings from the operating system under which it was born (or cloned).

 

To get a file to accept data entry in another format, go to File > File Options... > Text and select 'Always use current system settings'. That will stop the complaining part. Insert Date follows the settings you have chosen here, so if you're geting "oddball" results, the problem is in your OS short date settings (provided you have chosen to use it).

 

Formatting a date field in Layout mode affects the display, but not data entry.

 

The default language in Storage is irrelevant for a date field (that's why it's dimmed). You should be able to change the font in Layout mode - but that only applies to that field instance on that layout.

Link to comment
Share on other sites

Thanks!

 

Upon opening the file I chose system format, changed my system format to 2006-08-21 style (which I believe it was when the file was created, but I'm not sure), and now I can enter dates with the Insert > Date shortcut.

 

However, I was still not able to change the font and language input setting for the field in one of the layouts. The other layouts are displaying in an English font with no problems. When a Japanese font is used, not only is the font Japanese, but the keyboard input changes to Japanese, which means that has to be toggled back to English before any edits (since the date numbers, even in Japanese, are entered in hankaku English figures and hankaku hyphens).

 

However, when I tried to change the font via right click > Date Format > Text Format, I got an error message telling me I couldn't do it -- unless I held down Command-Option? Option-Control? Whatever it was, I did it, and it worked.

 

Thanks again!

Link to comment
Share on other sites

When a Japanese font is used, not only is the font Japanese, but the keyboard input changes to Japanese

 

That is set in the Filemaker's preferences > Fonts: Synchronize input method...

 

I was still not able to change the font and language input setting for the field in one of the layouts

 

Try deleting the field and placing a fresh one on the layout?

Link to comment
Share on other sites

This thread is quite old. Please start a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

Terms of Use